Engine temp

289 - 351 cid Small Block Performance

Engine temp

Postby thrnelson » Wed Apr 17, 2019 7:48 am

I am having a strange issue I need some help with.

My engine will not warm up. I have a 180 degree thermostat in a mild 289, I drive around and the engine will hardly get over 120. I pulled the thermostat out so I could test it and found it stuck open. It was held open by two small tabs on each side. I dis-lodged it and tested it in hot water. Around 140 it started to open and at 180 it was completely open. I cooled it off and it closed again. I reinstalled it and this morning drove to work, ambient temperature was about 38 degrees F and the engine barely got to 110 degrees. The drive to work is about 18 minutes. Before I pull the thermostat again and replace it I wanted to get your two cents.

My specific questions are:

How long does it take your cars with a mild 289 to warm up?
Have any of you ever experienced this issue?

Thanks,
Trent
Image
thrnelson
 
Posts: 103
Joined: Thu Sep 10, 2015 11:58 am
Location: Binghamton, NY

Re: Engine temp

Postby poboyjo65 » Wed Apr 17, 2019 9:06 am

May be the gauge or wiring? Mine (180°) warms up in about 5-10 minutes. Heater starts getting warm in 3-4 minutes, & pretty hot in 10. your heater would be a good way to tell if it is running proper in the mornings. if the heat gets warm fairly soon then your thermostat started out closed & is starting to open up.
Image
347, 4sp, 9''
poboyjo65
 
Posts: 5321
Joined: Thu Oct 20, 2011 7:40 pm
Location: Camden, Tenn.


Return to Small Block V-8 Performance

Who is online

Users browsing this forum: No registered users and 1 guest